Großes Release 20171211 auf LEDE

Moin Moin Leute,

 

Es ist wieder soweit wir haben eine neue Firmware gebaut. Diesmal handelt es sich um ein großes Rundum-Update.
Für dieses Update gibt es allerdings ein paar Dinge zu beachten. Falls ihr zu irgendwelche Punkten fragen habt: Mail an die Info Adresse.

 

Erster wichtiger Hinweis

Ältere Firmware Versionen sollten vorher auf Version 20170822 [11]  upgraden, um möglichen Problemen vorzubeugen. Router, die den autoupdater an haben, sollten also bereits auf 20170822 sein und updaten somit auch automatisch auf die Version 20171211. Insbesondere gibt es ein Problem in allen Gluonversionen vor 2016.2.7, welches die x86 Systeme betrifft. Diese verlieren ihre Konfiguration, wenn sie auf Gluon 2017.1.x updaten. Ältere Firmwareversionen sollten vorher auf 20170822 [11] upgraden, bevor diese 20171211 installieren. Wer den autoupdater deaktiviert hat, kann mit folgendem Befehl automatich updaten.
autoupdater -f
Der autoupdater sorgt dafür, dass alle Router zunächst mal auf  Version 20170822 (Gluon 2016.2.7) und erst von dort dann weiter auf die 20171211 (Gluon 2017.1.4). Auch wenn später noch Router mit noch älteren Versionen aus dem Schrank geholt werden, updaten die zuerst einmal auf die 20170822.

 

Zweiter wichtiger Hinweis

Für alle, die Setups mit PoE-Passthrough betreiben. Wenn ihr auf Nummer sicher gehen wollt, dass alle eure PoE-Passthrough Geräte das Ausrollen der Firmware heile überstehen, solltet ihr dort, wo PoE-Passthrough aktiviert ist, sicherstellen, dass _nicht_ genau dann vorne in der PoE-Kaskade ein reboot stattfindet, wenn weiter hinten geflasht wird. Mit anderen Worten es sollte genug Zeit nach dem Update der hinteren Router vergangen sein, bevor die vorderen updaten. Die eleganteste Möglichkeit hierzu ist wohl, die Minuten der cronjobs auf den einzelnen Routern entsprechend anzupassen. Hierzu mit vi in der /usr/lib/micron.d/autoupdater die erste Spalte bearbeiten. Danach noch /etc/init.d/micrond reload ausführen. Diese variante ist allerdings nicht update fest und ist somit beim nächsten update nicht mehr exsistent!

 

Alternativ kann man den Autoupdater deaktivieren und das Update zu einem Zeitpunkt händisch ausführen, wenn sicher ist, dass die per PoE-Passthrough betriebenen Geräten das Update bereits installiert haben. Folgender Befehl tut das:

 

Um zu prüfen das PoE-Passthrough aktiv ist. Wenn der zurück gelieferte wert 1 ist, ist es aktiv.

uci get system.gpio_switch_poe_passthrough.value
Dann könnt ihr mit folgendem Befehl den autoupdater ausschalten.

uci set autoupdater.settings.enabled='0'
uci commit autoupdater
Ob und welcher Aufwand sich lohnt muss jede/r selbst entscheiden. Das bricken eines Routers kann mit einer gewissen Warscheinlichkeit passieren, muss aber nicht.

 

Dritter wichtiger Hinweis

Ein potentielles Problem betrifft die meisten Virtuellen Maschinen. Die Gluon 2017.1.x images sind größer als die 2016.2.x images. Dies betrifft die x86 Architektur. Wenn deine Festplatte auf 2016.2.x images basiert, muss diese auf 273MB order größer vergrößert werden. Dies solltest du vor den update auf 20171211 machen! Der Befehl für qemu wäre z.b. folgender:

qemu-img resize $IMAGE 273MB

(mehr …)

Großes Update des Monitoring Scripts

Hallo Freifunker,

wir planen für heute Abend 19:00 Uhr ein größeres Update des Monitoring Scripts Nodewatcher. Dabei kann es zu Problemen kommen, wenn einzelne Router nicht ganz mitspielen. Das Update wird 3 Pakete auf den Routern installieren, die der neue Nodewacher benötigt sowie natürlich den neuen Nodewatcher. Die Pakete sind LibCurl, Curl und Ip.

Das Update betrifft alle Router auf die ich nicht per SSH Zugreifen kann und wird über die Auto-Update Funktion eingespielt, sofern diese eingeschaltet ist. Welche Router das genau betrifft und ob du dabei bist steht hier.

Wenn dein Router um 19:45 Uhr nicht wieder online ist, ist beim Update ein Fehler aufgetreten und wir werden uns wohl oder übel mal zur Reparatur treffen müssen. In diesem Fall bitte unter fragen@freifunk-ol.de melden.

Sollte von einem möglichen Ausfall einer von euch betroffen sein bitten wir darum für die dauer des Ausfalls bis vermutlich nächste Woche auf einen alternativen Internetplatz wie die Unibibliothek oder die Stadt Bibliothek im PFL auszuweichen.

Das Update wird aus Performancegründen durchgeführt, da wir mit der derzeiten Funktionsweise des Nodewatchers an die grenzen unseres Servers stoßen.